Since v6.1 OpenXava needs Java 8 or better

Java 6 (until v6.0.2)

By default, OpenXava is compiled with Java 6, so you can use OpenXava with WebSphere 8 and WebLogic 10. However, the application server included in the OpenXava distribution is Tomcat 9 (since OpenXava 6) that requires Java 8. Therefore, you need to use Java 8 (or better) to follow the introduction documentation to OpenXava.
If you want to use Java 6 with OpenXava follow the next steps: