Since v5.0 OpenXava needs Java 6
Since v4.0 OpenXava needs Java 5

Java 1.4 (until v3.1.x)

By default, OpenXava comes compiled with Java 5, you can recompile it with Java 1.4 following the next steps inside Eclipse:
Obviously if you want to use POJOs + JPA + Java 5 annotations you must use Java 5. Java 1.4 only works for classic XML components.