openxava / documentación / Eclipse

Desde v6.4 OpenXava incluye OpenXava Studio, por lo que no necesitas un IDE adicional para trabajar con OpenXava. OpenXava Studio está basado en OpenXava pero es más ligero y bonito. Además, puedes instalar cualquier plugin de Eclipse que necesites en OpenXava Studio y cambiar el tema visual, para poner un tema claro o iconos con color, por ejemplo. De todas formas, si prefieres trabajar con tu propio Eclipse también es posible. Además, los proyectos OpenXava son proyectos WTP, por lo que si usas Eclipse IDE for Enterprise Java Developers, puedes añadir un servidor Tomcat en la pestaña Servers tab y añadirle tu aplicación OpenXava.

Instalar Lombok

OpenXava no requiere Lombok, sin embargo desde la versión 6.5 lo usamos en la guía de primeros pasos y en el curso de OpenXava, por lo que te recomendamos que lo instales. Sigue la documentación oficial para instalar Lombok en tu Eclipse.

Usar workspace de OpenXava

Después de iniciar tu Eclipse éste te preguntará que selecciones un worspace, selecciona la carpeta workspace incluida en tu distribución de OpenXava:
switch-workspace_es.png
Probablemente Eclipse se quejará de la versión del workspace (demasiado nuevo o demasiado viejo) con un diálogo como este:
newer-workspace-version-message.png
No hagas caso y pulsa en Continue.
Si lo has hecho bien, verás los proyectos Addons y OpenXava a la izquierda, dentro del Package Explorer, de esta forma:
initial-openxava-workspace-with-eclipse.png
Si no, no estás en el workspace de OpenXava, usa File > Switch Workspace para buscar el workspace de OpenXava otra vez.
Para que el workspace de OpenXava funcione bien has de seleccionar el tema Dark. En el menú de arriba selecciona Window > Preferences > General > Appearance:
eclipse-change-to-dark-theme.png
Elige Dark para Theme y pulsa en el botón Apply and Close.

Crear un nuevo proyecto Java

Has de crear un nuevo proyecto Java convencional, para ello escoge File > New > Project en el menú:
create-new-project-menu.png
Después selecciona Java Project y pulsa en Next:
select-java-as-type-project.png
Ahora teclea el nombre del proyecto, Facturación por ejemplo, y pulsa en el botón Finish:
create-new-java-project-wizard_es.png
Si estás usando Java 9 o superior con una versión reciente de Eclipse, te preguntará:
Asking for module name
Pulsa en Don't Create.
Después de este paso ya tienes un proyecto Java vacío llamado Facturacion:
bare-java-project_es.png

Convierte el proyecto en un proyecto OpenXava

Ahora has de convertir tu proyecto Java simple y llano en un proyecto OpenXava. Dentro del proyecto OpenXava tienes un archivo CrearNuevoProyecto.xml, ejecutalo como un Ant Build, de esta manera:
run-crear-nuevo-proyecto.png
Ahora refresca tu proyecto con F5 y ya estás listo para seguir la guía de primeros pasos:

Sigue la guía Primeros pasos